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Registration
Windows Easy Menu requires registration.  The registration fee is $15.  Site 

licenses are available for multiple copies.  The fees are:

Copies Fee

1 to 10 $15.00 each
11 to 30 $15.00 each for first 10 copies, $10.00 each for copies in excess of 10
31 or more $10.00 each for first 30 copies, $5.00 each for copies in excess of 30

To register, send your payment (cash, money order, or check in U.S. funds) with the 
order form included in the distribution file (ORDER.TXT).  The order form may also be 
used to purchase a Windows Easy Menu diskette or printed user's manual.  Send your
order to:

Glen S. Tittermary
P.O. Box 1641

Richmond, Virginia 23213

Record your license number here:  ________________________________

Software License Agreement
Windows Easy Menu is furnished only on the condition that the purchaser agrees to 
the following terms and conditions:

1.  Windows Easy Menu remains the property of the author, but the author grants the
purchaser a nonexclusive license to use it subject to this agreement.

2.  The purchaser agrees not to copy, disassemble, or alter the software without 
permission of the author.

3.  If the software does not perform as described in this manual, the purchaser's 
license fee shall be returned if the author is notified in writing.  The author assumes 
no liability for any damage or loss caused by the use of this software.  This software 
is provided "as is" without any warranty of any kind, either expressed or implied.
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1.  Introduction

General Description

Windows Easy Menu (WEM) is a menu system for Microsoft Windows 3.0.  It 
makes user-defined applications available with a single click of the mouse or press of 
a key.  In addition, it makes all of the Windows Desktop Accessories or user defined 
accessories available on the same menu.  Applications may be Windows applications 
or DOS programs.  Version 3.0 is fully compatible with Windows 3.0 (and will not run 
under previous versions of Windows).  Windows Easy Menu has complete keyboard 
support, so it is an excellent Windows applications manager for laptops and other 
systems without a mouse.

Program Features

This version of WEM includes support for start-up directories for each menu 
item, and each item can be started as either a window, icon, or full screen.
 

Version 3.0 includes the WEM Menu Editor, which makes maintenance of your 
menus much easier.  With the editor, you can clear, insert, and delete menu items.  
The editor also provides printer support, so all of the menu data can be printed.

Some of the features of WEM include:

Features from Version 2.0

Up to 60 applications in 6 menus

Start all of the Windows desktop accessories from the menu

Turn the accessories menu on/off

Start the Program and File Managers from the menu

Run applications from a command line

Minimize the menu on start of applications

Specify the Windows start-up shell

Specify applications to auto-start when Windows is loaded

Complete keyboard support for all features -- great for laptops

New Features for Version 3.0

Command Bar -- pushbuttons for changing menus, accessories menu
on/off, menu editor, update menus, and exit
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All new Menu Editor -- insert, delete, clear items -- undo edits -- print 
menu data -- test menu item data

Complete directory support -- specify start-up directory for each 
application

Specify whether an application will start as a window, an icon, or full 
screen

Replace Windows Accessory menu with user-defined accessory menu

Complete error checking and reporting

Save the menu window position

System info dialog box -- reports Windows version, operating mode, 
free memory, disk space, etc.

Start menu with list of menus

Specify initial file for the Windows accessories

Turn date/time display on/off

Longer menu names -- up to 40 characters

Longer item names -- up to 20 characters

Organizing Your Menus

With WEM 3.0 you can construct up to six independent menus with 10 items 
each, for a maximum of 60 menu items.  How you organize the items in your menus 
will have a lot to do with how easy and convenient WEM is to use.  There are many 
ways to organize the menus, so the decision on what is best for you will depend on 
your specific situation.  The suggested organizations below are only three of the ways
you might want to consider.

Organizing by Type of Application.  One way to set up the WEM menus is 
to have each menu contain different types of applications.  Menu 1 might contain 
word processing and text editing applications, for example, while Menu 2 could 
contain speadsheet and database programs.  Menu 3 could have drawing, graphics, 
and presentation applications.  Menu 4 might contain entertainment and game 
programs.  The menu names for these four menus would describe the types of 
applications they contain:  Word Processing, Data Analysis, Drawing and Presentation 
Tools, and Entertainment.

Organizing by Task.  Another way to organize your menus is by the tasks 
you complete.  This type of organization is useful if you want to use the same 
applications for several menu items, but with different start-up files (as command line
parameters) or start-up directories.  For example, a small consulting firm might have 
one menu for each current project.  Each menu would contain a word processing 
menu item, a project management item, a speadsheet item, and a desktop 
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presentation item.  The menu items would have different start-up directories which 
were created for the exclusive use of the appropriate project.  So, when the 
applications are started, the current working directory would be the directory for the 
desired project.

Organizing Sequentially.  If you do not have many applications, it may be 
more useful to simply list the applications alphabetically in the first couple of menus. 
When the first menu is full, go on to the next and continue with the listing.  With the 
menu scroll buttons on the Command Bar (see Using Windows Easy Menu below) this 
can be a quick and easy way to access the menu items.

Quick Setup

To configure Windows Easy Menu for your system, you will need to:  (1) install 
the program files and start WEM, (2) enter the information for the menus, and (3) 
update the menu listings in WEM.

Install the Program Files and Start WEM.  WEM is distributed as a ZIP file.
To install the necessary files you need to "unzip" the files to your Windows directory.  
The following files are included in the distribution ZIP file:

menu.exe Main WEM program
menuedit.exe Menu editor program
mconvert.exe Program to convert version 2.0 files to 3.0
menu.wri This user's manual
order.txt Order form for license, diskette, manual

The file "menu.ini" is created the first time you run WEM (unless you are using an 
earlier version).

After the program files have been placed in your Windows directory, start 
WEM from the Program Manager or the File Manager by executing the file menu.exe.  
When the program starts a dialog box will be displayed requesting a license number.  
Until you receive a license, click Cancel and the WEM window will be displayed.  You 
are now ready to enter the menu data.

Important Note for WEM Version 2.0 Users:  WEM 3.0 uses a new file 
format for the menu data.  Users of version 2.0 will need to run 
MCONVERT.EXE to convert their menu.ini file to the new format.  You do not 
have to retype your menus  -- the Mconvert program will make all of the necessary 
changes for you.  To make the conversion, start WEM as usual.  All of the menu items 
should be "Reserved."  Select Run! from the menu and when the Run... dialog box 
appears, enter mconvert.exe and click the OK button.  When the WEM Menu File 
Conversion program starts, select Convert! from the menu.  After the conversion is 
complete, close the conversion program and select Update Menus from the Menu 
menu in WEM.  Your menus will be ready to use, so you can skip the next two steps of
the quick setup.  

Set up the Menu Items.  Start the WEM Menu Editor to set up the 
applications to be run from  each of the six menus.  To start the editor, select the 
WEM Menu Editor... item under the Menu menu.  (Note:  The Editor is a separate 
program, so you can also start it from the Program Manager or File Manager; the file 
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name is menuedit.exe.)  When the Editor starts, the six menus will be listed in the 
main window.  You can select the menu you want to edit by clicking anywhere on the 
menu listing with the left mouse button.  Or, you can use the arrow keys to select the
menu to be edited.  The selected menu will have a red border around it.

After you have selected the menu you want to edit, select Edit! on the menu 
bar.  The Menu Items... dialog box will appear.  First, select the Menu Name field 
(with the mouse or the TAB key) and type the name of the menu.  The name will 
appear in the WEM Menu pull-down menu and in the Windows Easy Menu title bar.  
You should make the name descriptive, but not too long.  A maximum of 40 
characters is permitted.

Now you are ready to set up the applications to be run from the menu.  
Windows Easy Menu can start up to ten applications in each menu.  Applications are 
loaded according to the information you supply in the Menu Items... dialog box.  For
each application, you enter a label, a command line, a start-up directory, and 
whether you want the application to start as a window, icon, or full screen.

The label is the name of the application that you want to appear next to the 
button in the menu.  The label can be up to 20 characters long.  For example, the 
label for Microsoft Excel might be MS Excel.

The command line consists of the executable program to be run, and any 
optional parameters.  For example, to run Microsoft Excel, you would enter the 
command line:  excel.exe.  To start Excel with a spreadsheet named "budget.xls" 
loaded on start-up, the command line would be:  excel.exe budget.xls.

The start-up directory is the directory you want to use as the working 
directory when the application starts.  For example, if Excel is in the directory "c:\
excel," but your spreadsheets are in a directory called "data" on drive c:, you could 
specify a start-up directory as:  c:\data.  When Excel is started, the "data" directory 
would be active (when you open or save files, for example).  The start-up directory is 
also useful for DOS programs that use configuration files, or for files that are in 
directories that have not been included in your PATH statement.

Finally, select the way you want the application to start:  as a window, an icon,
or as the full screen.  When using a mouse, just click the radio button for your 
selection.  If you are using the keyboard, use the TAB key to move to the Start as... 
group, and then use the arrow keys to select the start-up mode.

Use the Next pushbutton to advance to the next menu item.  Enter the data 
for the item, and continue for as many menu items as you want.  When all of the 
menu items have been entered, click the Save button to save your menu data to the 
"menu.ini" file.  The menu data you have entered will be lost if you select a 
different menu or exit without saving it.  After you have saved your data, the 
Menu Items... dialog box will be closed.  Now you can Exit the editor.

Update the Menus.  When you return to Windows Easy Menu from the 
editor, your changes will not appear on the menu.  To apply the edit you have made, 
select the Update Menus item under the Menu menu.  WEM will show the labels 
you entered in the WEM Editor.  You are now ready to use WEM to start the 
applications.  (For more information on how to use the editor, see section 3 of the 
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user's manual.)
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2.  Using Windows Easy Menu
The Windows Easy Menu Window

The Windows Easy Menu window has six major parts, as shown in the figure 
below.  You use different parts of the the window to accomplish different tasks.

Figure 1
The WEM 3.0 Window

The Title Bar.  At the top of the window is the title bar, along with the system
box and a minimize button.  The title bar will always show the name of the currently 
selected menu.

The Menu Bar.  The menu bar has five items.  The Menu item is used to 
select  a menu, to start the WEM Menu Editor, to update the menus after they have 
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been edited, and to exit the program (or to exit Windows if WEM is the system shell). 
The Run! item displays a dialog box in which you can enter a command line to 
execute applications.  The Accessories item is used to start each of the Windows 
Desktop Accessories or the user-defined accessories.  The Options item is used to 
select various options which control how WEM looks and operates:  the Windows 
Accessories and User Accessories items toggle the accessories menu between the
Windows Desktop Accessories and a set of user-defined accessories; the accessories 
pushbutton menu can be turned on or off; WEM can be minimized to an icon each 
time an application is run; the date and time display can be turned on or off; and the 
WEM position on the screen can be saved.  And finally, the Help item is used to 
display information about your system and about the WEM program.

The Command Bar.  Below the menu bar is the Command Bar.  The 
Command Bar has seven pushbuttons which can be used to execute frequently used 
commands.  The first two buttons, < and >, are for scrolling through the six menus.  
The M button displays a dialog box with pushbuttons for selecting the menu to be 
displayed.  The A+/A- button is for turning the accessories pushbutton menu on and 
off.  The E button is for starting the WEM Menu Editor.  The U button updates the 
menus after they have been edited.  The X button exits the program (or exits 
Windows if WEM is the system shell).

The Applications Menu.  The next portion of the WEM window is the 
Applications Menu.  The Applications Menu consists of the ten pushbuttons used to 
start the applications that you specify.  The applications are defined with the WEM 
Menu Editor.

The Manager Menu.  Below the Applications Menu is the Manager Menu.  
This portion of the WEM window has two buttons for starting the Windows Program 
Manager and File Manager.

The Accessories Menu.  The bottom portion of the window is the 
Accessories Pushbutton Menu.  This menu is used to start each of the Windows 
Desktop Accessories or the user accessories.  The accessories pushbutton menu can 
be turned on or off as you prefer.

Entering Your License  

Use the order form included with WEM to order your license number.  When 
you obtain your license, start WEM and the Enter License... dialog box will appear.  
(The license number removes the license dialog box which appears when Windows 
Easy Menu is started.)  When the Enter License... dialog box appears, type your 
license number exactly as it appears on  your registration notification (capital letters 
must be typed as capitals, etc.).  If you are using a mouse, click the OK button.  If 
you are using the keyboard, press the TAB key to select the OK button, then press 
the SPACE BAR.  (Note:  After WEM has been started, you can also enter your 
license by selecting the Enter License... item from the Options menu.)

Selecting a Menu

There are several ways to select a menu, or to change from one menu to 
another.  The most convenient for you will depend on how you are using the system 
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and whether you have a mouse.

Using the Menu.  To select the menu you want to use, choose the Menu 
item in the Windows Easy Menu menu bar.  Then click the menu you want.  A check 
mark will appear next to the currently selected menu.

Using the Command Bar.  To change menus with the Command Bar, click 
the M pushbutton.  The Select Menu... dialog box will appear.  Click the pushbutton 
for the menu you want.  If you do not know where a menu item is on a menu, you can
scroll through each of the menus by clicking the < or > pushbuttons in the Command
Bar.

Using the Keyboard.  The keyboard can be used to scroll through the menus
just as the < and > pushbuttons function in the Command Bar.  The left and up arrow
keys select the previous menu; the right and down arrow keys select the next menu.  
You can also press the [M] key to display the Select Menu... dialog box.

Starting Applications on the Applications Menu

You can start the applications on your menus with the mouse or the keyboard. 
The keyboard interface is especially useful for laptops and other systems which do 
not use a mouse.

Using the Mouse.  To start an application on the Applications Menu, click on 
the appropriate button.  Just click the button once -- don't double click as you would 
on the Program Manager.

Using the Keyboard.  If you are working without a mouse, you can start the 
application by pressing the number key corresponding to the button.  You may use 
either the number keys above the letters or the numeric keypad.

Running an Application not on the Menu

On occasion you may want to run an application not on your Applications 
Menu.  To do this, select the Run! item from the menu bar.  When the Run... dialog 
box appears, type the command line you want and click the OK button or press the 
RETURN key.

Selecting Windows Accessories or User Accessories

Windows Easy Menu includes a menu for accessories.  The accessories are 
utility applications that are generally available to the user regardless of which of the 
six application menus may be displayed.  WEM supports two types of accessories:  
(1) those supplied with Windows, and (2) utilities which the user supplies from other 
sources.  The Windows Accessories include such utility programs as a clock, a 
cardfile, a paint program, a calculator, the control panel, etc.   User accessories might
include a text editor, a graphics file viewer, a screen blanker, etc.  And of course, you 
could define some of the Windows Desktop Accessories as user accessories also.

You can select between Windows Accessories and user accessories in the 
Options menu.  Select Windows Accessories... if you want the Accessories menu 
to include the 12 Desktop Accessories.  Select User Accessories... if you want the 
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Accessories menu to include the nine accessories you have defined.  To define the 
user accessories you use the Menu Editor (described section 3 of this manual).

Turning the Accessories Menu On/Off

Windows Easy Menu includes a pushbutton menu for all of the 12 Desktop 
Accessories included with Windows or for nine user-defined accessories.  You can turn
this pushbutton menu on or off as you prefer. 

Using the Menu.  The first time you start Windows Easy Menu, the 
Accessories menu will be on.  To turn it off, select Accessories Menu from the 
Options menu.  This configuration will be saved, so the next time Windows Easy 
Menu is started your preference will be used.  To turn the Accessories menu back on, 
select Accessories Menu again from the Options menu.

Using the Command Bar.  As an alternative, you can use the A- pushbutton 
on the Command Bar to turn the Accessories Menu off.  The A+ pushbutton turns the 
Accessories Menu on.

Using the Keyboard.  If you are working without a mouse, the [+] and [-] 
keys can be used to turn the Accessories Menu on and off.

Note:  The pushbuttons for the Program Manager and the File Manager are 
always available, even with the Accessories Menu turned off.
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Starting the Windows Desktop Accessories

If you have the Accessories menu configured for the Windows Desktop 
Accessories, you can start the accessories in several different ways.

Using the Accessories Menu.  To run a Windows Desktop Accessory from 
the pushbutton menu, click on the appropriate button on the Accessories Menu.

Using the Keyboard.  When the Accessories Menu is turned on, you can also
use the keyboard to start the accessories.  Press the letter key corresponding to the 
pushbutton.  The appropriate letter is the one underlined in the pushbutton.

Using the Menu.  If you prefer, the Desktop Accessories can be run by 
selecting the accessory from the Accessories menu on the WEM menu bar.  Even if 
you have the Accessories pushbutton menu turned off, the accessories can be run 
from the pull-down menu.

Starting the User-Defined Accessories

If you have the Accessories menu configured for  accessories you have 
defined, you can start the accessories in several different ways.

Using the Accessories Menu.  To run a user-defined accessory from the 
pushbutton menu, click on the appropriate button on the Accessories Menu.

Using the Keyboard.  When the Accessories Menu is turned on, you can also
use the keyboard to start the accessories.  Press the function key you assigned to the
accessory in the menu editor to start the accessory.  

Using the Menu.  If you prefer, the user-defined accessories can be run by 
selecting the accessory from the Accessories menu on the WEM menu bar.  Even if 
you have the Accessories pushbutton menu turned off, the accessories can be run 
from the pull-down menu.

Configuring Minimize on Run

You can make Windows Easy Menu minimize to an icon each time you run an 
application or accessory  by selecting Minimize on Run from the Options menu.  A 
check  mark will appear next to Minimize on Run when the option is active.  To turn 
it off, select it again.

Configuring the Date/Time Display

WEM will display the current date and time at the far right end of the 
Command Bar.  This is the default configuration.  If you want to turn the display off, 
select Date/Time Display on the Options menu.  To turn the display back on, select
Date/Time Display again.  When the display is on, a check mark appears next to 
the menu selection.

Saving the WEM Window Position

By default, the WEM window will center itself on the screen.  You can override 
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this default by moving WEM to the position you want it on the screen and selecting 
Window Position Save under the Options menu.  The position you selected will be 
saved, and used whenever you start WEM.  To return to the default, select Window 
Position Center from the Options menu.

Getting System Information

Sometimes it is necessary to get information about your system, such as how 
much free memory or disk space is currently available.  You can get a report on 
system information by selecting System Info... from the Help menu.  The WEM 
System Information dialog box opens and displays  the current version of Windows;
whether Windows is operating in real, standard, or 386 enhanced mode; the 
microprocessor type for your system; whether a math coprocessor is present in the 
system; the amount of free memory in the system; and the amout of free disk space 
on the currently selected drive.  Click the OK button to close the dialog box. 

Exiting from Windows Easy Menu

To exit, select Exit (or Exit Windows... if Windows Easy Menu is the system 
shell) from the Menu pull-down menu.  Or you can click the X pushbutton on the 
Command Bar.  If you are using the keyboard, you can just press the [X] key.
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3.  Using the WEM Menu Editor

The WEM Menu Editor is used to create, edit, delete and print the menus used 
by WEM.  It is also used to configure certain features of WEM.

The WEM Menu Editor Window

The Editor window has three major parts:  a title bar, a menu bar, and a menu 
listing window.

Figure 2
The WEM Editor Window

The Title Bar.  As with all Windows applications, the title bar shows the name
of the application.

The Menu Bar.  The Editor menu bar has four items.  The File item is used to
print the menu data, to save the Editor window position and size, and to exit.  The 
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Edit! item displays the dialog box used to edit the menus.  The Options item is used
to set various configuration options for WEM.  The options include the Windows 
system shell, the applications to start automatically when Windows starts, the initial 
files to load for the desktop accessories, and whether to start WEM with a list of the 
menus.  The Help item includes the About... dialog box.

The Menu Listing Window.  The Menu Listing Window shows the menu 
name and item labels for all six of the WEM menus.  Note that if your menu name is 
long, only the first 20 characters will be displayed.  The currently selected menu is 
outlined with a red border.  The selected menu is the one that will be edited when 
you select the Edit! command, or printed when you select the Print Current Menu 
command.  When the Editor starts, the currently active menu in WEM will be 
selected.  To select another menu click on the listing with the left mouse button, or 
move the red selection border with the arrow keys.

Creating and Editing a Menu

To create or edit a menu, select the menu on the menu listing window.  Click 
the Edit! command in the menu bar.  The Menu Items... dialog box will be 
displayed.

Creating a New Menu.  To create a new menu, select  an empty menu in the
menu listing window.  An empty menu will be labeled "untitled," and have a list of 10 
"Reserved" items.  Select Edit!  on the menu bar.  The Menu Items... dialog box will
be displayed.  First, type the name of the menu.  The name will appear in the WEM 
Menu pull-down menu and in the Windows Easy Menu title bar.  You should make the 
name descriptive, but not too long.  A maximum of 40 characters is permitted.

Next, you enter the information for the applications in the menu.  Windows 
Easy Menu can start up to ten applications in each menu.  Applications are loaded 
according to the information you supply in the Menu Items... dialog box.  For each 
application, you enter a label, a command line, a start-up directory, and whether you 
want the application to start as a window, icon, or full screen.

The label is the name of the application that you want to appear next to the 
button in the menu.  The label can be up to 20 characters long.  For example, the 
label for Microsoft Excel might be MS Excel.

The command line consists of the executable program to be run, and any 
optional parameters.  For example, to run Microsoft Excel, you would enter the 
command line:  excel.exe.  To start Excel with a spreadsheet named "budget.xls" 
loaded on start-up, the command line would be:  excel.exe budget.xls.

The start-up directory is the directory you want to use as the working 
directory when the application starts.  For example, if Excel is in the directory "c:\
windows," but your spreadsheets are in a directory called "data" on drive c:, you 
could specify a start-up directory as:  c:\data.  When Excel is started, the "data" 
directory would be active (when you open or save files, for example).  The start-up 
directory is also useful for DOS programs that use configuration files, or for files that 
are in directories that have not been included in your PATH statement.

Finally, select the way you want the application to start:  as a window, an icon,
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or as the full screen.  When using a mouse, just click the radio button for your 
selection.  If you are using the keyboard, use the [TAB] key to move to the Start 
as... group, and then use the arrow keys to select the start-up mode.

Use the Next pushbutton to advance to the next menu item.  Enter the data 
for the item, and continue for as many menu items as you want.  When all of the 
menu items have been entered, click the Save button to save your menu data to the 
"menu.ini" file.  The menu data you have entered will be lost if you change 
the selected menu or exit without saving it.  After you have saved your data, 
the Menu Items... dialog box will be closed.

Editing an Existing Menu.  To edit an existing menu, select the menu in the 
menu listing window.  Select Edit! on the menu bar. The Menu Items... dialog box 
will be displayed.  Use the Next or Prev pushbuttons to select the menu item you 
want to edit.  Remember, if you are using the keyboard, you can select all the 
pushbuttons by pressing the key corresponding to the letter underlined on the 
pushbutton.  Use the mouse or [TAB] key to position the text cursor to the text you 
want to edit.  To change an existing item you can just retype the new menu data, 
using the [DELETE] or [BACKSPACE] keys as necessary.  If you change your mind 
about your edit, you can click the Undo button to restore the original text.  
Remember to Save the changes before you select another menu or exit from the 
dialog box.

The editor also permits more sophisticated editing of your menus.  In the 
lower right corner of the Menu Items... dialog box are four pushbuttons for special 
editing functions.  With these buttons you can Clear, Insert, and Delete your menu 
items. If you change your mind about an edit, you can Undo all of the editing actions 
since the last Save. 

Clearing an item simply deletes the current text in the edit boxes and replaces
it with the defaults for an empty item.  You click the Clear pushbutton to clear the 
currently displayed item.  Click the Undo pushbutton to restore the text.

Inserting an item moves the items prior to or after the currently selected item 
so that a new menu item can be added to the menu.  How the insert is accomplished 
by the Editor depends on where "Reserved" items remain on the menu -- if 
"Reserved" items are below the inserted item (have a higher item number), the 
existing items are moved down, and the "Reserved" item will be deleted;  if a 
"Reserved" item is above the inserted item (has a lower item number), the items 
above are moved up to fill the "Reserved" item.  You click the Insert pushbutton to 
insert an item.  Click the Undo pushbutton to remove the inserted item and restore 
the menu to its previous order.

Deleting an item removes the currently selected item from the menu, moves 
the items below it on the menu up one position, and inserts an empty "Reserved" 
item at the end of the menu.  You click the Delete pushbutton to delete an item.  
Click the Undo pushbutton to restore the deleted item and move the items below it 
back to their original positions.

Testing the Menu Data.  The Test pushbutton is used to determine if the 
menu information you have supplied can be used by WEM to execute the application 
in the way you intended.  When you click the Test pushbutton the Editor performs 
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the following tests:  (1) parses the item label so you can see how it will appear on the
menu, (2) determines if the command line executable file can be found, (3) checks 
the start-up drive and directory to determine if they actually exist on your disk, (4) 
checks the start-as mode to make sure that an appropriate mode is specified in the 
"menu.ini" file, and (5) parses the command line parameters so you can see them in 
the final test report.  After the test is complete, a report dialog box will be displayed.  
Any potential errors in your menu data will be reported.  See the Troubleshooting 
section below for an interpretation of each of the error messages. 

Deleting a Menu.  The final editing function in the Menu Items... dialog box
is the Delete Menu pushbutton.  This button is in the upper portion of the dialog 
box, next to the Exit pushbutton.  You use this button to delete an entire menu from 
the "menu.ini" file.  This action cannot be undone, so make sure you really want to 
delete a menu before clicking this button.  If you do, you will be asked to confirm the 
action before the deletion takes place.  Click the No button to cancel the delete 
action.

Printing a Menu

The WEM Editor can print all of the data associated with your menus.  To print 
a menu, select the menu you want to print by clicking on it in the main window (or 
move the selection box with the arrow keys), and select Print Current Menu from 
the File menu.  The Editor prints to the default printer for Windows, using the current
settings for the printer.

Saving the Editor Screen Position

Once you have resized the Editor main window to the size and position you 
like, you can save the position to be used whenever you start the Editor.  Select Save
Editor Position from the File menu to save the current position and window size.
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Selecting the System Shell

The sytem shell is the program that runs when you first start Windows.  When 
you installed Windows, Program Manager was set up as the shell.  But you can select 
other programs as shells if you wish.  The System Shell... item in the Options 
menu will configure the shell you want.  If you decide to use Windows Easy Menu on a
regular basis you can set it as the shell.  Click the button for the shell you want and 
then click the OK button.  The shell will be effective the next time you start Windows.

Setting Up Applications for Auto Start

If you select Windows Easy Menu as the system shell, you can specify that 
certain applications run when you start Windows.  Three applications can be started 
as full windows and an additional three applications can be started as icons.  To 
configure the applications to run, select the Auto Start... item from the Options 
menu.  Enter the program names you want to run and to load as icons.  Remember, if
a program is not in a directory specified in your path statement, you will need to 
enter a complete path and filename in the Auto Start... dialog box (and it's 
preferable to enter the complete path anyway, because the application will load 
faster).  You can move from one field to the next by pressing the [TAB] key.  Click OK
or press the [RETURN] key to save your configuration.

Setting the Initial Files for Windows Accessories

On some occasions it may be useful to have the Windows Desktop Accessories
load an initial file when they are started.  This is especially useful for an accessory 
such as Calendar, for which you would normally use the same calendar file each time 
it is started.  The Editor can be used to specify the initial file for each of the 
accessories (that can open a file).  To specify files for the accessories, select 
Accessories... from the Options menu.  The Initial Accessory File... dialog box 
will be diplayed.  For each of the accessories listed, type in the file you want to have 
loaded when the accessory starts.  You can use the [TAB] key to skip down to the 
next item.  You do not have to specify a file for all of the accessories, only for the 
ones you want to open an initial file.  Click the OK pushbutton to save your set-up to 
the "menu.ini" file.  Click Cancel if you want to exit without saving the changes.

To cancel the settings for the initial file, you simply delete the filename 
specified in the Initial Accessory File... dialog box.

Setting Up the User Accessories

The WEM Accessories menu can be configured with either the Windows 
Desktop Accessories or with nine accessories which you define.  To set up your own 
set of accessories, select User Accessories... from the Options menu.  In the 
dialog box that is displayed, you enter the name to appear on the face of the 
pushbutton and the command line to be executed when the button is pushed.  The 
command line can consist of the executable file name plus any command line 
parameters.  When WEM starts accessories it assumes they are in your Windows 
directory, and you should normally put accessories in that directory.  If your 
accessories are elsewhere, you will have to include the path as a part of the 
command line; the accessory will start, but the Windows directory will remain active.
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Note that each accessory you define is assigned to one of nine function keys.  
When the Accessories pushbutton menu is active in WEM, you can use the assigned 
function key to start the accessory.

Once you have defined all of the accessories, click the OK pushbutton.  To use
the accessories you have defined, return to WEM, update the menus by clicking the U
pushbutton in the Command Bar, and select User Accessories from the Options 
menu.

Listing Menus on Start-up

If you use a large number of applications on the six menus you may want to 
start WEM with the list of menus instead of with Menu 1.  You can make the Select 
Menu... dialog box in WEM display automatically on start-up by selecting List 
Menus on Start from the Options menu.  A checkmark will appear next to this 
option if it  has been selected.  To turn off the option, select List Menus on Start 
again.

Exiting from the Editor

To exit the editor, select Exit from the File menu or double-click the system 
box.
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4.  Troubleshooting
WEM 3.0 provides for complete error checking and reporting.  Error and 

informational messages will be displayed when a command or other action cannot be
successfully completed.  Listed below are the WEM and WEM Editor error messages, 
the likely cause for each error, and the possible solutions to the problems.

WEM Error Messages

Too many clocks or timers.

This error means that too many programs which use the Windows timer (such 
as the Clock) are currently running.  WEM needs one of the timers to display the 
current date and time.  Close one of the applications and try to restart WEM.

The specified start-up directory is invalid.

The start-up directory that you entered for the application does not exist.  You 
may have misspelled it when entering it.  Use the WEM Editor to change the start-up 
directory to a valid DOS directory.

The specified start-up drive is invalid.

You specified a disk drive in the start-up directory that does not exist.  Use the
WEM Editor to change the start-up drive to a vaild drive on your system.

Insufficient memory to run application.

There is not enough memory to run the application.  If other applications are 
running, try closing some of them to free some memory.

Invalid path or filename.

The path or filename that you specified in the command line is invalid.  You 
may have misspelled it.  Use the WEM Editor to enter the correct path and filename 
for the application you want to run.

Unable to execute application.

WEM has encountered some problem while trying to execute the application.  
Close other applications, and be sure your command line is correct.

Unable to execute accessory.

WEM has encountered some problem while trying to execute an accessory.  If 
the accessory is a Windows Desktop Accessory, it probably is not in the Windows 
directory; be sure the accessories are properly installed in the Windows directory.  If it
is a user accessory, you may have misspelled the accessory program name when 
setting it up or it is not in the Windows directory; use the menu editor to check the 
information you supplied and enter a path in the command line if necessary. 
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Program Manager is already running.

You tried to start the Program Manager when it was already running.  Use the 
Task List to activate the Program Manager.

File Manager is already running.

You tried to start the File Manager when it was already running.  Use the Task 
List to activate the File Manager.

Incorrect license number entered.

The license number you entered was not valid.  Be sure you typed the number
exactly as listed on the registration notification.  Contact the author if the your 
license cannot be entered.

WEM Editor Not Found.

The file "menuedit.exe" could not be found.  This file must be in the Windows 
directory.  Contact the author if the file is not included in the distribution ZIP file you 
are using.

WEM Editor Error Messages

Cannot access printer driver.

This error occurs if the WEM Editor is unable to determine the type of printer 
you are using.  This information is contained in the "win.ini" file under the [Windows] 
section in a field labeled "devices=."  Use the Control Panel to set up a default 
printer.

Unable to start print job.

The WEM Editor was unable to initialize the printer spooler.  Be sure that the 
Print Manager is properly installed.

Are you sure you want to delete the menu: _________.

This is an informational message requesting confirmation before deleteing a 
menu.  This action cannot be undone, so only delete a menu if you are sure you no 
longer need it.

You do not need to insert.  The item is available for use.

You tried to insert when the current item is Reserved.  You do not need to 
insert.

Cannot insert. This menu is full.

You tried to insert a menu item in a full menu.  Only ten items can be listed in 
each menu.  Delete an item in the current menu, or try to insert in another menu with
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"Reserved" items.
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Problem Reporting

Please report any problems or suggestions for improvements to the following address
or contact the author on Compuserve:  71401,2413.

Glen S. Tittermary
P.O. Box 1641
Richmond, Virginia 23213
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